App is slow or erroring

Incident Report for Clockwise

Resolved

This incident has been resolved.
Posted Jan 12, 2023 - 15:41 PST

Update

This incident has been resolved.
Posted Jan 12, 2023 - 13:16 PST

Monitoring

We've identified the issue and rolled out a fix. We're monitoring now to confirm full restoration of performance.
Posted Jan 12, 2023 - 09:30 PST

Investigating

We are currently investigating an issue resulting in slow or degraded performance of Clockwise. We'll provide updates here as we identify and mitigate this issue. Thank you for your patience.
Posted Jan 12, 2023 - 09:21 PST
This incident affected: Web App and Chrome Extension.