Slack OAuth Authentication is broken

Incident Report for Clockwise

Resolved

This incident has been marked as resolved
Posted Feb 24, 2023 - 16:35 PST

Monitoring

Final update as we are marking the issue as resolved. After digging through some more, the issue happens consistently when using a particular OAuth provider, but we were not able to reproduce the issue with using our regular OAuth signup flow.
Posted Feb 24, 2023 - 16:22 PST

Identified

A hotfix for a particular edge case in relation to this issue is being deployed.
Posted Feb 24, 2023 - 15:22 PST

Update

Customer impact is significantly lower than we originally estimated and only affect particular users. Most signups are still successful. We're still working on determining the cause of the failure.
Posted Feb 24, 2023 - 12:27 PST

Update

We're currently investigating an issue that is preventing some customers from signing in or up using Slack's OAuth flow. We're currently investigating.
Posted Feb 24, 2023 - 11:58 PST

Investigating

We are currently investigating this issue.
Posted Feb 24, 2023 - 11:54 PST