Degraded App and Extension Access

Incident Report for Clockwise

Resolved

All services recovered after change to poll launch darkly was deployed.
Posted Oct 20, 2025 - 21:37 PDT

Monitoring

Issue appears to be mitigated. Root issue was Launch Darkly streaming API having intermittent failures due to the AWS issues today.
Posted Oct 20, 2025 - 20:40 PDT

Update

We're investigating degraded performance on the Clockwise app and extension. You may experience issues viewing events on your calendar or creating new events. We will post an update as we learn more or when the services are back to normal.
Posted Oct 20, 2025 - 18:59 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 18:59 PDT