Duplicate events on some users' calendars for some recurring meetings
Incident Report for Clockwise
Resolved
We have cleaned up all known duplicate events. If you have any further questions, please reach out to our support team. Thank you!
Posted Nov 01, 2023 - 22:15 PDT
Update
We're continuing to work on removing duplicated events from roughly 1,000 users' calendars. We're being thorough to ensure we only delete duplicated events. We'll keep providing updates as we continue to work on resolution.
Posted Oct 31, 2023 - 20:37 PDT
Update
Cleanup is on-going; we're being cautious to not introduce more problems. We have code changes in place to identify duplicated events. This will run overnight. Our expectation is that we'll remove duplicated events sometime tomorrow.

Apologies to any impacted users for the inconvenience.
Posted Oct 30, 2023 - 17:44 PDT
Update
We're continuing to work on cleaning up any impacted calendars and events.
Posted Oct 30, 2023 - 12:05 PDT
Monitoring
We've identified an issue with Clockwise that results in some recurring meetings managed by Clockwise being duplicated. We've rolled back the problematic changes so no new meetings should be duplicated. We're now moving onto cleaning up any impacted calendars. We'll keep providing updates as we continue to work on resolution.
Posted Oct 30, 2023 - 10:23 PDT